PAN003 NUC configuration issue


#1

I downloaded and installed Ubuntu 18.10 instead of 18.04.1 LTS. When I run ${POCS}/scripts/install/install-dependencies.sh I get an error message in the end “ERROR: don’t know which version of MongoDB to install”. As a consequence the following step “python ${POCS}/setup.py install” prompts various syntax error. I checked and I’m using python 2.7.15+
It seems other builders did not have any issue on this dependencies.sh script so it might be because of the ubuntu version??
I’m downloading 18.04.1 LTS, will test with it and update the post.


#2

I installed Ubuntu 18.04.1 LTS and followed the instruction. Now I have another “error message” after the prompt “Installing python packages using pip”.
Message is: “python setup.py egg_info” failed with error code 1 in /tmp/pip-install-vo7zet2o/astroscrappy/"
I felt brave enough to follow on and try the next line “pip install -r ${PAWS}/requirements.txt” which failed because pip had not been installed. So I followed on Ubuntu recommendation and installed pip “sudo apt install python-pip” and this seemed to run fine.
After that I could execute “pip install -r ${PAWS}/requirements.txt” without sudo (people commented on the instruction they had to do sudo and I had to do so yesterday also…" was ok.
I reran the dependencies script that went further than previously but ended again with an error after prompting “Installing built astrometry into directory /var/panoptes/astrometry, and logging to /var/panoptes/logs/install/20190130.232905/make-astrometry-install.log”
it says
ERROR: version mismatch after installing astrometry!
Expected: 0.76
Actual:
so to be clear a blank after Actual:
I tried to follow on but python ${POCS}/setup.py install resulted in another error message:
file “var/panoptes/POCS/setup.py”, line 7, in
from configparser import ConfigParser
ImportError: no module named configparser

When I query the version of python it gives me 2.7.15rc1 while I’ve been seing prompts about python3 and conda during the apt-get upgrade execution.
I read the $HOME/.profile and could not see any change since my edits as in the instruction.
And that’s all I had to sy about this…


PAN016 Intel NUC Setup Problem