PAN010: Build thread for UofA

Hi All,

This thread is being used for questions and status updates for PAN010, which is located in Tucson, AZ through the University of Arizona. We’re 3 graduate students (Jhen, Alex, Justin) getting our PhDs in Optical Sciences with Olivier as our co-adviser. It’s been going a bit slow for us, given that we have a lot of coursework and research demands to meet, but we’re getting through it.

Current status:

  • We’ve drilled the holes and all the boards have been built.
  • We lost our dovetail rail somewhere between moving our unit between buildings, so we recently purchased a new to fix up.
  • We’re currently testing and hooking up the electronics, which we’ll be able to strap down and move forward with the NUC configuration.
1 Like

Hi all, brief update and a question about the weather station incoming:

We’ve acquired all of the parts for the 2018 version of the pier mount, it should be finished when I find spots to machine over the next week or two.

We’re considering the appropriate weather station purchases and have been informed that the anemometer (wind speed sensor) may be unnecessary for monitoring our weather conditions. Considering we are largely concerned with monsoons and high heat (sometimes > 110 degrees F), we’re more inclined to focus on monitoring for rain and keeping the unit cool enough. For example, maybe another exhaust fan is in order on the electronics control box. This can really depend on the observation site for the unit, which we are still figuring out.

Thoughts, suggestions?

Keeping the control box cool may indeed be an issue. One possibility is to paint the lid white, though that plastic is hard to bond to. Another is to add another large pvc pipe for an exhaust fan (as opposed to pulling air in).

The same issue may apply to the camera box, but it at least has a lighter color.

I would definitely say you can skip the anemometer. It’s not worth the extra cost for most people.

Hello all, it’s been a while. Alex, Justin, and I are reunited once again at UA to continue assembling our PANOTPES unit. It got really busy here with the semester starting, but things are calmed down now.

Here’s some pictures of our unit’s progress:

Here’s what we have ahead of us:

  • Component placement inside control box
  • Power cables assembly (once we figure out how far away components will be positioned)
  • Weather proofing
  • Software testing

We’re pretty close to finishing up our unit. Once done, we’re planning to lug our unit to the roof of Steward Observatory for some overnight testing. (@oguyon , we may need your help if we need permission from Buell or someone else)

Here’s a list of questions we have for our unit:

  • Are there any set of instructions describing how to manage the USB and power cable from the control box to the camera box? With the telescope mount moving around, we don’t want to get the cables all tangled up. Currently, we’re putting the camera USB cable through the dovetail rail and it’s hanging out from there.

  • In @james.synge 's setup, we noticed the telescope mount had some sort of plastic casing for weather proofing. Are there any details regarding this?

  • We’re trying to figure out how to mount our electronics boards in the control box. We noticed in PAN012’s unit uses small metal posts to separate the power board off the pellican case. I’ve seen those before and I know I can probably buy them at my local hardware store, but we can’t remember for our lives what they’re called. Can @nem or anyone else provide any additional details? (Caltech reference post here)

1 Like

Great progress Jhen and the UofA team.

The answers to your three questions are:

  1. Yes there are instructions for making the cable between the head unit and the control box. These are for the latest build. Basically the cables now leave the front face of the unit between the lenses. The instructions have not been released yet as we are finalizing the edits. But Ill give you access early through slack.

  2. We have an old instruction set for water proofing. Read that. If you have further questions let us know.

  3. We have a new instruction set for mounting everything in the control box. Again it hasnt been released so Ill send it to you on slack. The rods are called stand offs. I found them in our electronics lab laying around. My job this week is to find similar parts on the web and add them into the parts list.

N

Hi Jhen
For 3), you could buy this kit to mount both boards. Has all the parts you need accept washers.

You could also use metal standoffs but it does not matter much.
Good luck
N

Thanks for the response, @nem! We appreciate all the help.

We’re likely going through with the kit mount set, once we check if the M3 screws can fit through the mounting holes of the power and telemetry boards (old versions). (@jmk1729 can you please verify?)

We’re currently assembling the control box. The most recent control box instructions don’t mention anything about powering specific components, particularly the components that require an outlet. Here’s a list of items we’re interested in:

  • Powered USB hub (it was suggested a couple months ago to use that instead, so we bought that)
  • Power Supply Unit
  • Cloud Sensor

Any suggestions?

The holes in the PCB should be large enough for M3 screws but you can double check tomorrow.

  • We did not use a powered USB hub in the control box and are not recommending that as a default. It depends what the connection is. If USB power it off the computer. You only need 1 device connected to it all the time. The other ports are for a mouse and keyboard you need to set things up. If it needs AC power, then for simplicity buy a power splitter and plug it in to the mains cable that comes from the outside world. This will work but isnt ideal. The best option, if it takes 12V to power, cut the power supply cable for the hub and connect it to the same port on the PCB board the NUC is connected to so they are power cycled together.

  • The power supply unit or UPS has its own instruction set James made for setup. Its somewhere on the panoptes drive. Hunt around for it.

  • We did not buy the cloud sensor yet. Dont need it until deployment which we are approaching now so didnt want to get distracted. From what I recall there will be a serial to USB cable you need to connect to the NUC, which can go via the hub, and the power cable needs to be cut and connected to the PCB board. It has its own port.

To connect things to the jacks on the PCB board, I use these parts:
https://www.amazon.com/female-Adapter-Connector-Terminal-2-1x5-5MM/dp/B076SXZK7M/ref=sr_1_1?ie=UTF8&qid=1527532418&sr=8-1&keywords=barrel+jack+screw+terminal&dpID=51QreWptDfL&preST=SY300_QL70&dpSrc=srch
These have worked well for us thus far.
Good luck
N

We have been working on running POCS on PAN010 and run in to some issues that we are struggling to solve. A brief list of some of the issues includes:

  • The cameras are mounted automatically when the NUC is powered on.

  • Our USB ports seem to change names on NUC restarts (what is /dev/ttyUSB1 becomes /dev/ttyUSB0 and so forth) so we have to change config files to get things to work

  • We are currently using the setup started by $POCS/scripts/startup/tmux_launch.sh. We get all the windows to execute, but don’t seem to be able to control anything due to a stale weather condition file marking it as unsafe. In looking at this, we have many questions about the using the weather sensor and the environment sensors (these are not even registering), as well as how to fake weather data to test the unit functionality indoors.

  • We have run pytest --with-hardware=all and seen only 4 fails. They didn’t seem to be too fundamental, but I can’t recall what they are at the moment.

  • We haven’t had much luck with using the cameras. We aren’t too familiar with Bash to understand why the scripts James wrote aren’t working for us.

We were wondering if we could set up a time in the near future to chat about our issues directly.

Thanks,
Alex

Hi Jhen
Some responses:

  • Yes cameras auto mount when they are connected to the NUC.
  • Yes USB port changes each time the comp reboots or you replug. This happens on PAN012 as well. If this is an issue we could try to make a simulink that try to create a link for the device based on its serial number and would therefore always be the same. We can talk to Wilfred and James about this.
  • To control the weather station if its not plugged in or night time you need to bypass it by running:

setup_pocs night weather
Check out the operation guide to PAN012 in the 2018_instructions directory. Aru wrote that for us but will be SUPER helpful for all. So have a look. Everything you could need is in there.

  • Aru and Montu had these as well. We never worked through them. Check out the Software_suggestions document in the 2018_instructions directory as they may have written about it in there.
  • Forget bash. To simply take images, follow the gphoto2, notebook or pocs_shell instructions in the PAN012 operations guide Aru wrote (mentioned above).
    Good luck
    N

Hi all, it’s time for some PAN10 updates.

Here’s what we’ve done so far since last week:

  • We went through @nem’s documents and we were able to do the nightweather bypass.
  • We ran the polar alignment scripts to test camera initialization with POCS.
  • We successfully controlled the mount and took some pictures.
  • Note that these activities were done in an office room and not outdoors (yet).

Here’s new problems we encountered:

  1. We cannot upload code to the arduino micros using the NUC.
  • When we try to upload code from the NUC to the arduino and checked with ‘strace’, it stated that the devices were busy.
  • We thought it was a permission problem, so we poked around the permissions and connections if the NUC detected any devices.
  • We checked that PANOPTES was in the ‘dialout’ group.
  • However, when we probed the serial ports using ‘screen/dev/ttyACM1’, we ruled out permission problems because it was printing outputs.
  • One putput looked like the code was running fine, but we got another output that said ‘attentione 5V 1023’ and we’re not sure which board produced that output.
  • When we plugged in the circuit board Arduinos into Alex’s laptop as opposed to the NUC, all the scripts uploaded without any problems and ran just fine.
  • We wanted to confirm that there wasn’t a problem with our NUC when an arduino is connected to it and powered by the NUC. To do this, we plugged in a spare arduino not inserted in a circuit board into the NUC and uploaded code using the same arduino IDE version (we downloaded the most updated version from the Arduino website). This worked successfully, so we are guessing that there is a problem with the common ground in our system. Note that the NUC is being powered off mains power with its own power supply, not the power board.
  • So, we tried to make the power cable for the NUC, and that leads us to the second problem.
  1. We’re having trouble powering the NUC from the power board.
  • We made a cable to power the NUC from the power board.
  • We cut an old laptop charger with the same size screw-on connector plug (2.5mm inner diameter plug)
  • Before plugging this cable into the NUC, we plugged in this cable to the NUC port on the power board and measured the output voltage. We measured 11 V here.
  • We plugged this cable into the NUC. The NUC powers on, but the NUC turned off immediately.
  • We hit the power button again on the NUC, and it powered up, but it displayed “Power Processor Thermal Trip” on the connected monitor.
  • We booted into the BIOS anyways, and we adjusted all the temperatures to set up a more aggressive cooling threshold.
  • After exiting the BIOS to reboot, the NUC still shut itself off. So there’s enough power to run the BIOS, but not to boot. This has been a repeatable test.

Any opinions on what’s going on? Troubleshooting tips are greatly appreciated.

Thanks for the update. A few comments:

  • You should not being having issues with the micro/uno and the NUC. You should not have to make custom cables and so on. Just make sure your power board does have a short in the wrong place and the wiring is correct (im assuming the arduinos are on the boards right)? It could also be the micro itself. If you have a spare try that. James and Wilfred might be able to give you more advice on arduinos.

  • The NUC power is concerning. My guess is you guys possibly got the polarity wrong on the cable you cut. Note, not all cables have center pin active. You need to take the existing NUC power supply and measure is the center pin or the outside is active. Once you have this you need to triple check you wired up the NUC cable to the power board the right way.

  • The 11V is not an issue. A NUC will work till the Voltage is just below 9V. So this isnt a problem. If you dont believe, take you cable, plug it into a variable power supply that can output at least 2A of current and try turn on the NUC.

  • Another issue it can be is if you use a very thin cable. Thin cables cant carry the current and will heat and have a voltage drop. So try and get an appropriate gauge cable for powering the NUC as the beast can draw 3A.

Try these things and let me know.

Have you been able to try any of Nem’s suggestions? Nem may be right about the NUC being able, sometimes, to work down to 9V, but they are rated for 12V to 19V DC (or at least the two I’ve purchased). After the battery died in PAN001, it wasn’t possible to boot the NUC until some manual, local reset was performed. Wilfred can provide more details.

Which AC-DC power supply are you using? It should be producing somewhere near 13.5V DC when operating on AC. Is it?

I would be very sceptical about putting anything less than 12V to the NUC. As James mentioned they are actually rated up near 19V and they want to use power. Turning up the cooling threshold (meaning it cools more) would actually be drawing more power as then you are running the fans higher.

Regarding the custom cable, do you mean that you are actually wiring together two separate wires? I believe I just took an existing cable that was used with a 12V wall wart and snipped it to cut off the actual wall wart. If you are using your own wires make sure they are not thin and crappy, as Nem mentioned. I’m using 18 gauge wires for anything I have carrying power.

Note, however, that everything I am mentioning is on PAN008 and I am not using the custom power board (I am building one soon).

After the battery died in PAN001, it wasn’t possible to boot the NUC until some manual, local reset was performed. Wilfred can provide more details.

Correct, the NUC has some bios options that allow it to reboot on power failure but if it reboots and there is still limited power it will stop during BIOS setup and give a warning that must be manually dismissed. I’m not sure there is a work-around for this other yet. Most modern laptops have the same thing.

Also, make sure you have disabled unnecessary items in the BIOS. Things like the Sound Card eat up a lot of power even if you are not using them. Disable HDMI if you can, which might not be feasible in the lab if you have a monitor plugged in.

@jlumbres can you let us know the NUC model number you are using? Also, does this have a solid state hard drive?

Hi all,

Sorry for the long gap in between updates.

Addressing Nem’s comments: we cut the NUC power supply cable to power the NUC using the custom power board. It works, unlike the laptop charger cable. We’re guessing its failure may have to do with Nem’s suggestion about center pins or too thin of a gauge to handle that much current.

We can upload the camera and telemetry board sketches to readout the reported information from both of the Arduino micros when they are plugged into a separate computer (e.g. one of our laptops) while everything except for the weather station is powered through the power board, but we cannot upload the same sketches when the micros are plugged into the NUC. This is one of our bigger concerns, as right now our unit can run, but won’t function autonomously in real weather conditions.

Our AC-DC power supply unit is the PowerStream PST-SP12AL. We measure 12 V DC converted from mains power.

We use the NUC5i5RYK, but looking back at our parts list, I see the hyperlink points to the NUC5i3RYK. Maybe we bought something which nominally requires more power than the custom power board can provide, at least without restricting its performance in the BIOS? Could this be why we get thermal trips when resetting the device? This model has a solid state hard drive. We have turned off the audio and bluetooth options in the BIOS. We still use a monitor, so we have not disabled HDMI/display ports yet.

As far as running the unit, we tested it out on the UofA lawn during the Thanksgiving break. We sorted out a number of practical issues (cable lengths, powering the unit, focusing the cameras), but we need a better location to perform a real polar alignment - street lights plagued our field of view. We are requesting access to put the unit up on the roof of Steward Observatory so we can ‘calibrate’ it and maybe try to measure a transit curve in the near future.

Regards,

Justin

Thanks @jmk1729 for the response. The sketches only need to be uploaded once so if you can do it on your laptop it should just work from there unless I’m misunderstanding. If you are just trying to connect to it from the Arduino IDE from the NUC in order to read the sensor values that might be a problem. But if you have successfully uploaded it once via your laptop we can then try to use the actual POCS scripts to read the values from the NUCs, which doesn’t need the Arduino IDE at all. Let me know if I’m misunderstanding though.

Should be fine. I think this is what @james.synge has.

Hi all,

We are trying to calibrate the current sensors on the first gen power board. We’ve followed the instructions Luc wrote, but we’ve gotten stuck. The output voltage to the Arduino micro (through the ribbon cable) always reads about 2.8 V from every device voltage on pin - regardless of the load - when we try to change the pots (V_ref and gain) on the appropriate current sensor. As we understand it, this reading should change, so we think we’re doing something wrong. This is the case for our board as well as the one we are borrowing from Hilo.

Here are some pictures of our setup. Note in the first picture we show the entire testing setup with power being supplied. The power supply is providing 12 V to the board and 5 V on the header pins for the ribbon cable. We have a DMM measuring the current across the middle 2-pin header and a second DMM measuring the output voltage to the Arduino from the ribbon cable header pins 9 and 11. This is depicted in the third image. We have a few power resistors (3, 5, 10 Ohms). The current we measure with a load is consistent with what we expect.



HI @jmk1729, I don’t see @lucboucher tagged in this thread, so I’m just writing a note to see if he has thoughts on this. @nem and @james.synge can probably offer insight as well.

Hi,
this is correct you should see the voltage output of the current sensors changing while changing the offset and gain pots even without load actually.
Thanks for the pictures:

  1. I see you bring the 5V using the upper pins (+5V on the left p-1 and GND on the right p-14). I see another GND contact (black wire on p-11). And you seem to be measuring signal on p-9 that is the signal needed to switch the MOUNT on/off. This should not be 2.8V but 5V but just in case please verify this.
  2. To remove any confusion you could measure directly on the daughter board of the current sensor its output voltage going to the Arduino (measure between Pin Vo and GND). Check also that 5V is actually getting to the current sensor boards by measuring bewteen pins +5V and GND on the pins of the current sensor daughter board.

Let me know how it goes.

Luc